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Important Information
Except as otherwise expressly stated in the License that accompanies a program, Texas
Instruments makes no warranty, either express or implied, including but not limited to
any implied warranties of merchantability and fitness for a particular purpose,
regarding any programs or book materials and makes such materials available solely
on an "as-is" basis. In no event shall Texas Instruments be liable to anyone for special,
collateral, incidental, or consequential damages in connection with or arising out of the
purchase or use of these materials, and the sole and exclusive liability of Texas
Instruments, regardless of the form of action, shall not exceed the amount set forth in
the license for the program. Moreover, Texas Instruments shall not be liable for any
claim of any kind whatsoever against the use of these materials by any other party.

License

Please see the complete license installed in C:\Program Files\TI Education\<TI-Nspire™
Product Name>\license.

Mac® is a trademark of its owner.

© 2012 - 2016 Texas Instruments Incorporated
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Using the TI-Nspire™ Computer Link Software
The TI-Nspire™ Computer Link Software lets you do the following:

• Transfer documents between your computer and a TI-Nspire™ handheld.

• Install a Chinese-English dictionary on a TI-Nspire™ CX-C or TI-Nspire™ CX-C CAS
handheld.

• Capture images from a TI-Nspire™ handheld screen and use them in TI-Nspire™
documents and computer documents.

• Update the operating system (OS) software on a TI-Nspire™ handheld or Lab
Cradle.

Opening the TI-Nspire™ Computer Link Software
1. Connect a TI-Nspire™ handheld or TI-Nspire™ Lab Cradle to your computer and turn

it on.

Note: The software works with TI-Nspire™ handhelds and TI-Nspire™ Lab Cradles
only. You cannot use it to communicate with other TI handhelds, such as a
TI-92 Plus. To communicate with those handhelds, use the TI Connect™ software
(version 1.6 or later).

2. Double-click the TI-Nspire™ Computer Link icon on the desktop.

The software displays a list of connected handhelds and lab cradles to select from.

Notes:

- You can communicate with only one handheld or Lab Cradle at a time.
- If your handheld or Lab Cradle is connected to your computer but is not listed,

click Refresh to update the list.
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3. Click the handheld or Lab Cradle you want to connect to.

4. Click Select.

The Explorer tab is displayed.

Selecting Among Multiple Handhelds or Lab Cradles
You can switch to a different handheld or Lab Cradle anytime you are using TI-Nspire™
Computer Link Software.

1. Connect the handheld or Lab Cradle to the computer.

2. Click at the lower right corner of the TI-Nspire™ Computer Link Software

window.

3. Click the handheld or Lab Cradle name, and then click Select.

Exploring Handheld Contents
The Explorer tab lets you view the contents of a connected handheld and transfer
(copy) documents between your computer and the handheld. You can also rename and
delete handheld documents and folders.



À Column headings. In the detail view, click a heading to sort the list. Click again to
reverse the order.

Á Folders and files residing on your computer.

Â Split bar – Drag up and down to show more or fewer files.

Ã Folders and documents residing on the selected handheld.

Selecting the View Format

Note: You can click the Refresh button anytime to refresh the file and folder lists.

▶ Click View > Detail View or click to view details of the files and to sort the list.

▶ Click View > List View or click to view a list of only the file names.

▶ Click View > Show Folder View to show the structure of computer and handheld
folders in a separate pane on the left.

▶ Click View > Hide Folder View to hide the folder structure.

Viewing Contents

1. If the Explorer is not visible, click the Explorer tab.

2. In the folder view, click any folder to show its contents in the right panel.
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Copying Documents or Folders

• TI-Nspire™ Computer Link Software allows only TI-Nspire™ handheld documents to
be copied to a handheld. If you inadvertently try to copy other types of files, or a
folder containing other types of files, TI-Nspire™ Computer Link Software notifies
you and cancels the copy operation. 

• Only subfolders can reside within the Documents folder on the handheld.

• You can drag handheld files and folders only to locations within the TI-Nspire™
Computer Link Software application window. You cannot drag them outside the
window.

• The only file you can copy to the TI-Nspire™ Lab Cradle is the .tlo file, the Lab
Cradle operating system.

Copying Documents or Folders by Dragging

You can use the mouse to drag to copy documents between a handheld and the
computer or between two folders on the computer You can drag to copy folders
between a handheld and the computer.

1. Click the document or folder that you want to copy.

Note: You can select multiple documents or folders by holding down the Ctrl key
(Mac®: “) and clicking each one separately.

2. Drag the selection, and drop it on the desired destination.

The selected items are copied to the destination.

Note: If a folder or document of the same name already exists at the destination,
you are asked if you want to replace it.

Copying Documents and Folders by Pasting

You can use the Clipboard to copy documents and folders. If you want to move an item
instead, copy it, and then delete the original.

1. Click the document or folder to be copied.



Note: You can select multiple items by holding down the Ctrl key (Mac®: “) and
clicking each item.

2. Click Edit > Copy to copy the selected items to the Clipboard.

3. Click a folder to select it as the destination.

4. Click Edit > Paste.

Explorer copies the items to the destination folder.

Note: If the destination already contains a document with the same name as the one
you are copying, you can choose to either replace the existing document or cancel.

Canceling a Transfer in Progress

As long as the File Transfer window is displayed, you can cancel a transfer. Only the
files that have not already been transferred are canceled.

▶ In the File Transfer window, click Cancel.

Creating a New Folder on the Handheld

You can create a new folder within the Documents folder on the handheld. You can
create file paths that contain up to 10 folder levels.

1. Click the handheld name in the TI-Nspire™ File Browser.

2. Click File > New folder.

TI-Nspire™ Computer Link Software creates a folder named Folder# and selects the
name so you can edit it.

3. Type a name for the new folder and press Enter.

Renaming Documents and Folders on a Handheld

Note: TI-Nspire™ Computer Link Software does not let you change a document’s file
name extension.

1. Click the document or folder name and then click File > Rename.

The name is highlighted to show that you can edit it.
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2. Type the new name and press Enter.

Deleting Documents on a Handheld

When you delete a document, it is permanently deleted and cannot be recovered.

▶ Click the document name, and then click Edit > Delete.

Before deleting the document, Explorer asks you to confirm that you want to delete
it.

Notes:

• You can select multiple documents to delete by holding down the Ctrl key (Mac®:
“) and clicking each document. When you click Delete, Explorer deletes all the
selected documents.

• You cannot delete files on the computer.

Deleting a Folder on a Handheld

When you delete a folder, the folder and all documents within it are permanently
deleted and cannot be recovered.

▶ Click the folder name and then click Edit > Delete.

Before deleting the folder, Explorer asks you to confirm that you want to delete it.

Notes:

• You can select multiple folders to delete by holding down the Ctrl key (Mac®: “)
and clicking each folder. When you click Delete, Explorer deletes all the selected
folders.

• You cannot delete the Documents folder on the handheld.

• You cannot delete folders on the computer.

Viewing Details
TI-Nspire™ Computer Link Software can display the following information about your
handheld or Lab Cradle:



• Device type: Handheld or Lab Cradle

• Device ID

• Operating System (OS) version

• Total storage capacity

• Space used

• Free space

To view details:

1. Connect the handheld or Lab Cradle you want to view.

2. Open the TI-Nspire™ Computer Link Software.

3. Click Tools > Show Device Info.

The device information is displayed. You can use your mouse to highlight and copy
text.

Note: If you receive an error that says “Device is not responding,” check to make sure
the handheld or Lab Cradle is connected firmly and try again.

Installing the Dictionary on a Handheld
You can install a Chinese-English dictionary on the TI-Nspire™ CX-C and TI-Nspire™ CX-C
CAS handhelds. Use the dictionary to look up English words in Chinese, and to look up
Chinese words in English. The dictionary gives the translation and definitions of a word.

Note: The option to install the dictionary does not appear in the software for any
handheld other than the TI-Nspire™ CX-C and TI-Nspire™ CX-C CAS handhelds.

You can install the dictionary on one handheld at a time.

Note: After the dictionary is installed, it cannot be deleted.

1. Connect the handheld to your computer.

2. Click Tools > Install Dictionary.

The Install Handheld Dictionary dialog box opens, and the dictionary file is
displayed.

3. Click the dictionary file name to select it.
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If you have a different dictionary file saved on your computer, click Change
Dictionary. The Select Handheld Dictionary File dialog box opens.

Navigate to the folder on your computer where you saved the dictionary file, and
click Select Dictionary.

4. Click Install.

The dictionary installs on the connected handheld.

Capturing Screens from a Handheld
The Screen Capture tab lets you capture images of the screen from a connected
TI-Nspire™ handheld. You can then resize the images, add or remove borders, copy
them into documents, or save them as image files on your computer.



À Screen Capture tab

Á Screen Capture toolbar

Â Captured handheld screens (in thumbnail view)

A border is automatically added to each screen, but you can remove it. The size of a
captured screen is 326 pixels wide by 246 pixels high, with or without a border.

Capturing a Screen

1. Make sure the handheld is turned on and properly connected to your computer.

2. On the handheld, display the screen that you want to capture.

3. Click the Screen Capture tab in the TI-Nspire™ Computer Link Software window.

4. Click Tools > Take screenshot or click .

The Screen Capture window shows the captured image.
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Note: If you recently removed the border from a screen, new screens appear without a
border. If you recently added a border to a screen, new screens appear with a border.

Viewing Thumbnails of Captured Screens

You can view screens individually or as a group of images, called thumbnails. A
reference name is displayed under each image. The thumbnail view also lets you select
multiple screen images for copying, saving, and so on.

▶ To view screens as thumbnails, click View > Thumbnails.



▶ To view screens individually, click View > Single Screen.

Selecting Multiple Screens

Selecting multiple screens lets you quickly apply a modification to all of them. For
example, you can select several screens and then resize them or remove their borders.

1. If necessary, click View > Thumbnails to display the thumbnail view.

2. Use one of the following methods to select the screens.

• Click Edit > Select All or press Ctrl+A (Mac®: “+A) to select all the captured
screens.

• Click the first image that you want to select, and then hold down Ctrl (Mac®:
“) as you click each additional image.

• Select a range of images by clicking the first image in the range, holding down
Shift, and clicking the last image in the range.

Resizing Screens

You can save a larger or smaller version of a screen image by zooming in or out before
you save it.

▶ To display a larger screen image, click View > Zoom In or click .

▶ To display a smaller screen image, click View > Zoom Out or click .

Adding or Removing a Border

The toolbar button for adding or removing a border toggles between add and
remove depending on whether the selected image contains a border.

Note: If you most recently removed the border from a screen, new screens appear
without a border. If you most recently added a border to a screen, new screens appear
with a border.

1. Click the screen capture image to select it.

2. Click Edit > Remove Border or click to remove the border.

– or –
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Click Edit > Add Border or click to add a border.

Adding or Removing a Border from a Group of Images

1. Click View > Thumbnails or click .

2. Select the group of images. You can either:

• Click the first image you want to select, and then hold down Ctrl (Mac®:“) as
you click each additional image.

• Select a range of images by clicking the first image in the range, holding down
Shift, and clicking the last image in the range.

3. Click Edit > Remove Border or click to remove the border.

—or—
Click Edit > Add Border or click to add a border.

Navigating Among Screen Images

▶ To view the previous screen image, click View > Previous Screen or click .

▶ To view the next screen image, click View > Next Screen or click .

Saving Captured Screens as Computer Files

You can save captured screens on your computer in TIF, GIF, PNG, or JPEG formats. The
screens are saved in your My Documents folder unless you specify a different location.
All screens are saved at the size they are currently displayed.

1. Select the captured screen or screens that you want to save.

2. Click File > Save Selected Screen(s) or click .

3. In the dialog box:

a) Navigate to the folder in which you want to store the screen capture file.

b) Select the file type for the appropriate image format.

c) Type a file name. Use a name that describes the screen image.

d) Click Save.



Notes:

• If you have previously saved the selected screen image, clicking File > Save Selected
Screen(s) or replaces the previous file. To save the file in a different location,

with a different name, or as a different file format, you must click File > Save
Selected Screen(s) As.

• To save all the images at once, click File > Save All Screens. When you do this, you
select the location to save the files in the Save All window, but you do not specify
file names. Each screen image is saved with its default file name. If that name
already exists, you’re prompted whether to replace the existing file.

• If you have unsaved screen images when you exit the TI-Nspire™ Computer Link
Software, you are prompted to save them. If you choose to save the images, they
are saved in your TI-Nspire™/Screen Captures folder.

Copying a Screen Image to a Computer Application by Dragging

1. Adjust the size of the TI-Nspire™ Computer Link Software window and the window
of the other application so that you can see both windows on the computer screen.

2. In the TI-Nspire™ Computer Link Software window, click the captured screen to
select it.

3. Drag the screen from TI-Nspire™ Computer Link Software and then drop it into the
other application.

Copying a Screen Image by Pasting

You can copy and paste a captured screen into an application that allows pasting
images.

1. Click the captured screen to select it.

2. Press Ctrl+C (Mac®: “+C) to copy the image to the Clipboard.

3. Click the other application at the point where you want to image to appear.

4. Press Ctrl+V (Mac®: “+V) to paste the image into the application.

Getting Help
Use the Help menu to find useful information to help you use the software more
productively. You can:

• Register your TI product.

• Check for updates to the software.
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• Check for updates to operating systems for TI-Nspire™ handhelds and the
TI-Nspire™ Lab Cradle.

• Download the latest guidebooks, which can help you:

- Find information easily and quickly.
- Learn how to perform new tasks more easily and efficiently.
- Improve your proficiency with the TI-Nspire™ applications.
- Eliminate the need to keep track of a printed book.

• Visit knowledge sites on the Internet to improve your proficiency with the product.
On these sites, you can find information about how to use TI products as well as
lessons, quizzes, and other instructive activities shared by educators.

Note: Activities available for download may vary depending on your geographical
region.

• Find information about the current software version.

Registering Your Product

1. Ensure you are connected to the Internet.

2. Click Help > Register to access the TI Registration Product site.

3. Follow the instructions on the website to complete the product registration
process.

Checking for Software Updates

If you are connected to the Internet and you have automatic notification enabled, your
system will notify you of any TI-Nspire™ software updates when you open the
software.

• The automatic check occurs once each time you open the software.

• If your system is up-to-date, you will not receive notification.

• You can turn off this feature if you don’t want to receive notifications
automatically.

• You can also check for updates manually.

Manually Checking for Software Updates

1. Click Help > Check for Software Updates.

If your software is current, the Check for Software Update dialog opens indicating
that you have the latest version of the software.



2. To turn off automatic notifications, clear the Automatically check for updates check
box. By default, this option is selected.

3. Click OK to close the dialog box.

Installing Updated Software

If your software needs to be updated, the Check for Software Update dialog box opens
with a message informing you that a newer version of the software is available.

To install the software update and manage your update notifications:

1. Check to make sure you’re connected to the Internet.

2. To turn off automatic notifications, clear the Automatically check for updates check
box.

3. Click Update to save the settings and begin the download.

A progress dialog box opens to show the download progress.

Note: If you receive a connection error, check your Internet connection and try again.

Checking for Handheld or Lab Cradle OS Updates

This option is active only if a handheld or TI-Nspire™ Lab Cradle is connected. To check
for OS updates for a connected, selected handheld or lab cradle, complete the
following steps.

1. Open the Content Explorer, and then select a connected handheld or lab cradle.

2. Click Help > Check for Handheld/Lab Cradle OS Update.

If the operating system is current, the Check for Handheld OS Update dialog box
opens indicating that the operating system on the handheld is current.
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3. To turn off automatic notifications, clear the Automatically check for updates check
box. By default, this option is turned on.

4. Click OK to close the dialog box.

Installing an Updated Operating System

If the operating system is not current on your handheld or Lab Cradle, the Check for
Handheld OS Update dialog box opens informing you that a newer version of the OS is
available.

1. Check to make sure you are connected to the Internet.

2. Click Install OS on my handheld/lab cradle.

You can also save a copy of the OS file on your computer by selecting the Save a
copy of the OS to check box. Click Browse to change the location where the OS file
is saved. You can install it later using Tools > Install OS.

3. Click Continue to download the OS and update the handheld or lab cradle.

4. Click Yes to confirm that you want to replace the OS file.

The License Agreement dialog box opens.

5. Accept the license agreement and click Continue.



6. When the message warning you that any unsaved data will be lost is displayed,
click Yes.

Note: Click No to cancel the update and save any unsaved documents, and then
restart the update process.

The Installing OS dialog box opens indicating the progress of the download.

When the download is complete, the Information dialog box opens informing you
that the OS has been downloaded and that you can disconnect the handheld or lab
cradle from the computer.

7. Click OK. The updated operating system is installed on the handheld or lab cradle.

When the update is complete, the handheld or lab cradle reboots.

Downloading the Latest Guidebook

1. Ensure you are connected to the Internet.

2. Click Help > Download latest Guidebook.

The Education Technology website opens with the Guidebooks tab active.

3. Click Sign In (located under the Search button on the right side of the banner).

The Sign In dialog box opens.

4. Type your user name and password, and then click Submit.

Note: If you don’t have an account, click Create Account.

5. Click the name of the Guidebook that you want to download.

The Guidebooks available for the product you selected are listed.

6. Click the title of the Guidebook you want to download.

A PDF verion of the Guidebook opens on your desktop.

Exploring TI Resources

The Help menu also provides links to TI resources and websites.

„ Click Help > Visit education.ti.com to access the Texas Instruments Education
Technology website.
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„ Click Help > Visit Activities Exchange to access the Texas Instruments Activities
Exchange, site, a forum where you can browse by subject to find ready-to-use math
and science learning activities appropriate for middle grades through college.

About the Software

Complete the following steps to open the About window, which provides legal
information about the software, indicates which version you have, and lists your
license number.

1. Click Help > About TI-Nspire™ <Product Name> Software.

Note: You do not need an Internet connection to open this window.

2. Click OK to close the window.



General Information

Texas Instruments Support and Service

General Information: North and South America

Home Page: education.ti.com
KnowledgeBase and e-mail inquiries: education.ti.com/support
Phone: (800) TI-CARES / (800) 842-2737

For North and South America and U.S.
Territories

International contact information: education.ti.com/support/worldwide

For Technical Support

Knowledge Base and support by e-mail: education.ti.com/support or
ti-cares@ti.com

Phone (not toll-free): (972) 917-8324

For Product (Hardware) Service

Customers in the U.S., Canada, Mexico, and U.S. territories: Always contact Texas
Instruments Customer Support before returning a product for service.

For All Other Countries:

For general information

For more information about TI products and services, contact TI by e-mail or visit the
TI Internet address.

E-mail inquiries: ti-cares@ti.com
Home Page: education.ti.com

Service and Warranty Information
For information about the length and terms of the warranty or about product service,
refer to the warranty statement enclosed with this product or contact your local Texas
Instruments retailer/distributor.
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